USN-753-1: PostgreSQL vulnerability

7 April 2009

postgresql-8.1, postgresql-8.3 vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 8.10
  • Ubuntu 8.04 LTS
  • Ubuntu 6.06 LTS

Software Description

  • postgresql-8.3
  • postgresql-8.1

Details

It was discovered that PostgreSQL did not properly handle encoding conversion failures. An attacker could exploit this by sending specially crafted requests to PostgreSQL, leading to a denial of service.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 8.10
postgresql-8.3 - 8.3.7-0ubuntu8.10.1
Ubuntu 8.04 LTS
postgresql-8.3 - 8.3.7-0ubuntu8.04.1
Ubuntu 6.06 LTS
postgresql-8.1 - 8.1.17-0ubuntu0.6.06.1

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

This update uses a new upstream release, which includes additional bug fixes. In general, a standard system upgrade is sufficient to effect the necessary changes.

References