USN-754-1: ClamAV vulnerabilities

7 April 2009

clamav vulnerabilities

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 8.10

Software Description

  • clamav

Details

It was discovered that ClamAV did not properly verify its input when processing TAR archives. A remote attacker could send a specially crafted TAR file and cause a denial of service via infinite loop. (CVE-2009-1270)

It was discovered that ClamAV did not properly validate Portable Executable (PE) files. A remote attacker could send a crafted PE file and cause a denial of service (divide by zero). (CVE-2008-6680)

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 8.10
libclamav5 - 0.94.dfsg.2-1ubuntu0.2

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system upgrade is sufficient to effect the necessary changes.

References