USN-755-1: Kerberos vulnerabilities

7 April 2009

krb5 vulnerabilities

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 8.10
  • Ubuntu 8.04 LTS
  • Ubuntu 7.10
  • Ubuntu 6.06 LTS

Software Description

  • krb5

Details

Multiple flaws were discovered in the Kerberos GSS-API and ASN.1 routines that did not correctly handle certain requests. An unauthenticated remote attacker could send specially crafted traffic to crash services using the Kerberos library, leading to a denial of service.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 8.10
libkadm55 - 1.6.dfsg.4~beta1-3ubuntu0.1
libkrb53 - 1.6.dfsg.4~beta1-3ubuntu0.1
Ubuntu 8.04 LTS
libkadm55 - 1.6.dfsg.3~beta1-2ubuntu1.1
libkrb53 - 1.6.dfsg.3~beta1-2ubuntu1.1
Ubuntu 7.10
libkadm55 - 1.6.dfsg.1-7ubuntu0.2
libkrb53 - 1.6.dfsg.1-7ubuntu0.2
Ubuntu 6.06 LTS
libkadm55 - 1.4.3-5ubuntu0.8
libkrb53 - 1.4.3-5ubuntu0.8

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

After a standard system upgrade you need to restart any services using the Kerberos libraries to effect the necessary changes.

References