USN-778-1: cron vulnerability

1 June 2009

cron vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 9.04
  • Ubuntu 8.10
  • Ubuntu 8.04 LTS
  • Ubuntu 6.06 LTS

Software Description

  • cron

Details

It was discovered that cron did not properly check the return code of the setgid() and initgroups() system calls. A local attacker could use this to escalate group privileges. Please note that cron versions 3.0pl1-64 and later were already patched to address the more serious setuid() check referred to by CVE-2006-2607.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 9.04
cron - 3.0pl1-105ubuntu1.1
Ubuntu 8.10
cron - 3.0pl1-104+ubuntu5.1
Ubuntu 8.04 LTS
cron - 3.0pl1-100ubuntu2.1
Ubuntu 6.06 LTS
cron - 3.0pl1-92ubuntu1.1

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system upgrade is sufficient to effect the necessary changes.

References