USN-784-1: ImageMagick vulnerability

8 June 2009

imagemagick vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 9.04
  • Ubuntu 8.10
  • Ubuntu 8.04 LTS
  • Ubuntu 6.06 LTS

Software Description

  • imagemagick

Details

It was discovered that ImageMagick did not properly verify the dimensions of TIFF files. If a user or automated system were tricked into opening a crafted TIFF file, an attacker could cause a denial of service or possibly execute arbitrary code with the privileges of the user invoking the program.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 9.04
libmagickcore1 - 7:6.4.5.4.dfsg1-1ubuntu3.1
Ubuntu 8.10
libmagick10 - 7:6.3.7.9.dfsg1-2ubuntu3.1
Ubuntu 8.04 LTS
libmagick10 - 7:6.3.7.9.dfsg1-2ubuntu1.1
Ubuntu 6.06 LTS
libmagick9 - 6:6.2.4.5-0.6ubuntu0.9

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system upgrade is sufficient to effect the necessary changes.

References