USN-785-1: ipsec-tools vulnerabilities

9 June 2009

ipsec-tools vulnerabilities

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 9.04
  • Ubuntu 8.10
  • Ubuntu 8.04 LTS
  • Ubuntu 6.06 LTS

Software Description

  • ipsec-tools

Details

It was discovered that ipsec-tools did not properly handle certain fragmented packets. A remote attacker could send specially crafted packets to the server and cause a denial of service. (CVE-2009-1574)

It was discovered that ipsec-tools did not properly handle memory usage when verifying certificate signatures or processing nat-traversal keep-alive messages. A remote attacker could send specially crafted packets to the server and exhaust available memory, leading to a denial of service. (CVE-2009-1632)

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 9.04
racoon - 1:0.7-2.1ubuntu1.9.04.1
Ubuntu 8.10
racoon - 1:0.7-2.1ubuntu1.8.10.1
Ubuntu 8.04 LTS
racoon - 1:0.6.7-1.1ubuntu1.2
Ubuntu 6.06 LTS
racoon - 1:0.6.5-4ubuntu1.3

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system upgrade is sufficient to effect the necessary changes.

References