USN-789-1: GStreamer Good Plugins vulnerability

22 June 2009

gst-plugins-good0.10 vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 9.04
  • Ubuntu 8.10
  • Ubuntu 8.04 LTS
  • Ubuntu 6.06 LTS

Software Description

  • gst-plugins-good0.10

Details

Tielei Wang discovered that GStreamer Good Plugins did not correctly handle malformed PNG image files. If a user were tricked into opening a crafted PNG image file with a GStreamer application, an attacker could cause a denial of service via application crash, or possibly execute arbitrary code with the privileges of the user invoking the program.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 9.04
gstreamer0.10-plugins-good - 0.10.14-1ubuntu0.1
Ubuntu 8.10
gstreamer0.10-plugins-good - 0.10.10.4-1ubuntu1.2
Ubuntu 8.04 LTS
gstreamer0.10-plugins-good - 0.10.7-3ubuntu0.3
Ubuntu 6.06 LTS
gstreamer0.10-plugins-good - 0.10.3-0ubuntu4.2

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system upgrade is sufficient to effect the necessary changes.

References