USN-797-1: tiff vulnerability

6 July 2009

tiff vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 9.04
  • Ubuntu 8.10
  • Ubuntu 8.04 LTS
  • Ubuntu 6.06 LTS

Software Description

  • tiff

Details

It was discovered that the TIFF library did not correctly handle certain malformed TIFF images. If a user or automated system were tricked into processing a malicious image, a remote attacker could cause an application linked against libtiff to crash, leading to a denial of service.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 9.04
libtiff4 - 3.8.2-11ubuntu0.9.04.1
Ubuntu 8.10
libtiff4 - 3.8.2-11ubuntu0.8.10.1
Ubuntu 8.04 LTS
libtiff4 - 3.8.2-7ubuntu3.2
Ubuntu 6.06 LTS
libtiff4 - 3.7.4-1ubuntu3.4

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system upgrade is sufficient to effect the necessary changes.

References