USN-808-1: Bind vulnerability

29 July 2009

bind9 vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 9.04
  • Ubuntu 8.10
  • Ubuntu 8.04 LTS
  • Ubuntu 6.06 LTS

Software Description

  • bind9

Details

Micha Krause discovered that Bind did not correctly validate certain dynamic DNS update packets. An unauthenticated remote attacker could send specially crafted traffic to crash the DNS server, leading to a denial of service.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 9.04
bind9 - 1:9.5.1.dfsg.P2-1ubuntu0.1
Ubuntu 8.10
bind9 - 1:9.5.0.dfsg.P2-1ubuntu3.2
Ubuntu 8.04 LTS
bind9 - 1:9.4.2.dfsg.P2-2ubuntu0.2
Ubuntu 6.06 LTS
bind9 - 1:9.3.2-2ubuntu1.7

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system upgrade is sufficient to effect the necessary changes.

References