USN-828-1: PAM vulnerability

8 September 2009

pam vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 9.04
  • Ubuntu 8.10

Software Description

  • pam

Details

Russell Senior discovered that the system authentication module selection mechanism for PAM did not safely handle an empty selection. If an administrator had specifically removed the default list of modules or failed to chose a module when operating debconf in a very unlikely non-default configuration, PAM would allow any authentication attempt, which could lead to remote attackers gaining access to a system with arbitrary privileges. This did not affect default Ubuntu installations.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 9.04
libpam-runtime - 1.0.1-9ubuntu1.1
Ubuntu 8.10
libpam-runtime - 1.0.1-4ubuntu5.6

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system upgrade is sufficient to effect the necessary changes.

References