USN-867-1: Ntp vulnerability

8 December 2009

ntp vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 9.10
  • Ubuntu 9.04
  • Ubuntu 8.10
  • Ubuntu 8.04 LTS
  • Ubuntu 6.06 LTS

Software Description

  • ntp

Details

Robin Park and Dmitri Vinokurov discovered a logic error in ntpd. A remote attacker could send a crafted NTP mode 7 packet with a spoofed IP address of an affected server and cause a denial of service via CPU and disk resource consumption.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 9.10
ntp - 1:4.2.4p6+dfsg-1ubuntu5.1
Ubuntu 9.04
ntp - 1:4.2.4p4+dfsg-7ubuntu5.2
Ubuntu 8.10
ntp - 1:4.2.4p4+dfsg-6ubuntu2.4
Ubuntu 8.04 LTS
ntp - 1:4.2.4p4+dfsg-3ubuntu2.3
Ubuntu 6.06 LTS
ntp - 1:4.2.0a+stable-8.1ubuntu6.3
ntp-server - 1:4.2.0a+stable-8.1ubuntu6.3

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system upgrade is sufficient to effect the necessary changes.

References