USN-89-1: XML library vulnerabilities

28 February 2005

libxml vulnerabilities

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 4.10

Software Description

Details

Several buffer overflows have been discovered in libxml’s FTP connection and DNS resolution functions. Supplying very long FTP URLs or IP addresses might result in execution of arbitrary code with the privileges of the process using libxml.

This does not affect the core XML parsing code, which is what the majority of programs use this library for.

Note: The same vulnerability was already fixed for libxml2 in USN-10-1.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 4.10
libxml1

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

References