USN-892-1: FUSE vulnerability

28 January 2010

fuse vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 9.10
  • Ubuntu 9.04
  • Ubuntu 8.10
  • Ubuntu 8.04 LTS
  • Ubuntu 6.06 LTS

Software Description

  • fuse

Details

Dan Rosenberg discovered that FUSE did not correctly check mount locations. A local attacker, with access to use FUSE, could unmount arbitrary locations, leading to a denial of service.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 9.10
fuse-utils - 2.7.4-1.1ubuntu4.3
Ubuntu 9.04
fuse-utils - 2.7.4-1.1ubuntu4.0.9.04.1
Ubuntu 8.10
fuse-utils - 2.7.3-4ubuntu2.1
Ubuntu 8.04 LTS
fuse-utils - 2.7.2-1ubuntu2.1
Ubuntu 6.06 LTS
fuse-utils - 2.4.2-0ubuntu3.1

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system upgrade is sufficient to effect the necessary changes.

References