USN-908-1: Apache vulnerabilities

10 March 2010

apache2 vulnerabilities

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 9.10
  • Ubuntu 9.04
  • Ubuntu 8.10
  • Ubuntu 8.04 LTS
  • Ubuntu 6.06 LTS

Software Description

  • apache2

Details

It was discovered that mod_proxy_ajp did not properly handle errors when a client doesn’t send a request body. A remote attacker could exploit this with a crafted request and cause a denial of service. This issue affected Ubuntu 8.04 LTS, 8.10, 9.04 and 9.10. (CVE-2010-0408)

It was discovered that Apache did not properly handle headers in subrequests under certain conditions. A remote attacker could exploit this with a crafted request and possibly obtain sensitive information from previous requests. (CVE-2010-0434)

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 9.10
apache2.2-common - 2.2.12-1ubuntu2.2
Ubuntu 9.04
apache2.2-common - 2.2.11-2ubuntu2.6
Ubuntu 8.10
apache2.2-common - 2.2.9-7ubuntu3.6
Ubuntu 8.04 LTS
apache2.2-common - 2.2.8-1ubuntu0.15
Ubuntu 6.06 LTS
apache2-common - 2.0.55-4ubuntu2.10

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system upgrade is sufficient to effect the necessary changes.

References