USN-919-1: Emacs vulnerability

29 March 2010

emacs22, emacs23 vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 9.10
  • Ubuntu 9.04
  • Ubuntu 8.10
  • Ubuntu 8.04 LTS

Software Description

  • emacs22
  • emacs23

Details

Dan Rosenberg discovered that the email helper in Emacs did not correctly check file permissions. A local attacker could perform a symlink race to read or append to another user’s mailbox if it was stored under a group-writable group-“mail” directory.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 9.10
emacs22-bin-common - 22.2-0ubuntu6.2
emacs23-bin-common - 23.1+1-4ubuntu3.2
Ubuntu 9.04
emacs22-bin-common - 22.2-0ubuntu2.9.04.1
Ubuntu 8.10
emacs22-bin-common - 22.2-0ubuntu2.8.10.1
Ubuntu 8.04 LTS
emacs22-bin-common - 22.1-0ubuntu10.2

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system upgrade is sufficient to effect the necessary changes.

References