USN-925-1: MoinMoin vulnerabilities

8 April 2010

moin vulnerabilities

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 9.10
  • Ubuntu 9.04
  • Ubuntu 8.10
  • Ubuntu 8.04 LTS
  • Ubuntu 6.06 LTS

Software Description

  • moin

Details

It was discovered that MoinMoin did not properly sanitize its input when processing Despam actions, resulting in cross-site scripting (XSS) vulnerabilities. If a privileged wiki user were tricked into performing the Despam action on a page with a crafted title, a remote attacker could exploit this to execute JavaScript code. (CVE-2010-0828)

It was discovered that the TextCha protection in MoinMoin could be bypassed by submitting a crafted form request. This issue only affected Ubuntu 8.10. (CVE-2010-1238)

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 9.10
python-moinmoin - 1.8.4-1ubuntu1.2
Ubuntu 9.04
python-moinmoin - 1.8.2-2ubuntu2.3
Ubuntu 8.10
python-moinmoin - 1.7.1-1ubuntu1.5
Ubuntu 8.04 LTS
python-moinmoin - 1.5.8-5.1ubuntu2.4
Ubuntu 6.06 LTS
python2.4-moinmoin - 1.5.2-1ubuntu2.6

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system upgrade is sufficient to effect the necessary changes.

References