USN-931-2: FFmpeg regression

26 April 2010

ffmpeg, ffmpeg-debian regression

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 9.10
  • Ubuntu 9.04
  • Ubuntu 8.10
  • Ubuntu 8.04 LTS

Software Description

  • ffmpeg
  • ffmpeg-debian

Details

USN-931-1 fixed vulnerabilities in FFmpeg. The update introduced a regression when trying to play certain multimedia files. This update fixes the problem.

We apologize for the inconvenience.

Original advisory details:

It was discovered that FFmpeg contained multiple security issues when handling certain multimedia files. If a user were tricked into opening a crafted multimedia file, an attacker could cause a denial of service via application crash, or possibly execute arbitrary code with the privileges of the user invoking the program.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 9.10
libavcodec52 - 4:0.5+svn20090706-2ubuntu2.2
libavformat52 - 4:0.5+svn20090706-2ubuntu2.2
Ubuntu 9.04
libavcodec52 - 3:0.svn20090303-1ubuntu6.2
libavformat52 - 3:0.svn20090303-1ubuntu6.2
Ubuntu 8.10
libavcodec51 - 3:0.svn20080206-12ubuntu3.3
libavformat52 - 3:0.svn20080206-12ubuntu3.3
Ubuntu 8.04 LTS
libavcodec1d - 3:0.cvs20070307-5ubuntu7.5
libavformat1d - 3:0.cvs20070307-5ubuntu7.5

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system upgrade is sufficient to effect the necessary changes.

References