USN-933-1: PostgreSQL vulnerability

28 April 2010

postgresql-8.1, postgresql-8.3, postgresql-8.4 vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 9.10
  • Ubuntu 9.04
  • Ubuntu 8.04 LTS
  • Ubuntu 6.06 LTS

Software Description

  • postgresql-8.4
  • postgresql-8.3
  • postgresql-8.1

Details

It was discovered that PostgreSQL did not properly sanitize its input when using substring() with a SELECT statement. A remote authenticated attacker could exploit this to cause a denial of service via application crash.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 9.10
postgresql-8.4 - 8.4.3-0ubuntu9.10.1
Ubuntu 9.04
postgresql-8.3 - 8.3.10-0ubuntu9.04.1
Ubuntu 8.04 LTS
postgresql-8.3 - 8.3.10-0ubuntu8.04.1
Ubuntu 6.06 LTS
postgresql-8.1 - 8.1.20-0ubuntu0.6.06.1

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system upgrade is sufficient to effect the necessary changes.

References