USN-936-1: dvipng vulnerability

6 May 2010

dvipng vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 10.04 LTS
  • Ubuntu 9.10
  • Ubuntu 9.04

Software Description

  • dvipng

Details

Dan Rosenberg discovered that dvipng incorrectly handled certain malformed dvi files. If a user or automated system were tricked into processing a specially crafted dvi file, an attacker could cause a denial of service via application crash, or possibly execute arbitrary code with the privileges of the user invoking the program.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 10.04 LTS
dvipng - 1.12-3ubuntu0.1
Ubuntu 9.10
dvipng - 1.11-1ubuntu0.9.10.1
Ubuntu 9.04
dvipng - 1.11-1ubuntu0.9.04.1

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system update will make all the necessary changes.

References