USN-937-1: TeX Live vulnerabilities

6 May 2010

texlive-bin vulnerabilities

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 10.04 LTS
  • Ubuntu 9.10
  • Ubuntu 9.04
  • Ubuntu 8.04 LTS

Software Description

  • texlive-bin

Details

It was discovered that TeX Live incorrectly handled certain long .bib bibliography files. If a user or automated system were tricked into processing a specially crafted bib file, an attacker could cause a denial of service via application crash. This issue only affected Ubuntu 8.04 LTS, 9.04 and 9.10. (CVE-2009-1284)

Marc Schoenefeld, Karel Šrot and Ludwig Nussel discovered that TeX Live incorrectly handled certain malformed dvi files. If a user or automated system were tricked into processing a specially crafted dvi file, an attacker could cause a denial of service via application crash, or possibly execute arbitrary code with the privileges of the user invoking the program. (CVE-2010-0739, CVE-2010-1440)

Dan Rosenberg discovered that TeX Live incorrectly handled certain malformed dvi files. If a user or automated system were tricked into processing a specially crafted dvi file, an attacker could cause a denial of service via application crash, or possibly execute arbitrary code with the privileges of the user invoking the program. (CVE-2010-0827)

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 10.04 LTS
texlive-binaries - 2009-5ubuntu0.1
Ubuntu 9.10
texlive-base-bin - 2007.dfsg.2-7ubuntu1.1
Ubuntu 9.04
texlive-base-bin - 2007.dfsg.2-4ubuntu2.1
Ubuntu 8.04 LTS
texlive-base-bin - 2007.dfsg.1-2ubuntu0.1

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system update will make all the necessary changes.

References