USN-938-1: KDENetwork vulnerabilities

13 May 2010

kdenetwork vulnerabilities

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 10.04 LTS
  • Ubuntu 9.10
  • Ubuntu 9.04

Summary

Software Description

  • kdenetwork

Details

It was discovered that KGet did not properly perform input validation when processing metalink files. If a user were tricked into opening a crafted metalink file, a remote attacker could overwrite files via directory traversal, which could eventually lead to arbitrary code execution. (CVE-2010-1000)

It was discovered that KGet would not always wait for user confirmation when downloading metalink files. If a user selected a file to download but did not confirm or cancel the download, KGet would proceed with the download, overwriting any file with the same name. This issue only affected Ubuntu 10.04 LTS. (CVE-2010-1511)

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 10.04 LTS
kget - 4:4.4.2-0ubuntu4.1
Ubuntu 9.10
kget - 4:4.3.2-0ubuntu4.1
Ubuntu 9.04
kget - 4:4.2.2-0ubuntu2.3

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

After a standard system update you need to restart your session to make all the necessary changes.

References