USN-951-1: Samba vulnerability

16 June 2010

samba vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 9.04
  • Ubuntu 8.04 LTS
  • Ubuntu 6.06 LTS

Summary

Remote code execution as root via Samba.

Software Description

  • samba - SMB/CIFS file, print, and login server for Unix

Details

Jun Mao discovered that Samba did not correctly validate SMB1 packet contents. An unauthenticated remote attacker could send specially crafted network traffic that could execute arbitrary code as the root user.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 9.04
samba - 2:3.3.2-1ubuntu3.5
Ubuntu 8.04 LTS
samba - 3.0.28a-1ubuntu4.12
Ubuntu 6.06 LTS
samba - 3.0.22-1ubuntu3.12

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system update will make all the necessary changes.

References