USN-955-1: OPIE vulnerability

21 June 2010

opie vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 10.04 LTS
  • Ubuntu 9.10
  • Ubuntu 9.04

Summary

Software Description

  • opie

Details

Maksymilian Arciemowicz and Adam Zabrocki discovered that OPIE incorrectly handled long usernames. A remote attacker could exploit this with a crafted username and make applications linked against libopie crash, leading to a denial of service.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 10.04 LTS
libopie-dev - 2.40~dfsg-0ubuntu1.10.04.1
Ubuntu 9.10
libopie-dev - 2.40~dfsg-0ubuntu1.9.10.1
Ubuntu 9.04
libopie-dev - 2.40~dfsg-0ubuntu1.9.04.1

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system update will make all the necessary changes.

References