USN-964-1: Likewise Open vulnerability

26 July 2010

likewise-open vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 10.04 LTS

Summary

Local login restrictions could be bypassed.

Software Description

  • likewise-open - Authentication services for Active Directory Domains

Details

Matt Weatherford discovered that Likewise Open did not correctly check password expiration for the local-provider account. A local attacker could exploit this to log into a system they would otherwise not have access to.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 10.04 LTS
likewise-open5-lsass - 5.4.0.42111-2ubuntu1.1

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system update will make all the necessary changes.

References