USN-968-1: Dell Latitude 2110 vulnerability

5 August 2010

base-files vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 10.04 LTS
  • Ubuntu 9.10

Summary

Insecure Apt configuration on Dell Latitude 2110.

Software Description

  • base-files - Debian base system files

Details

It was discovered that the Ubuntu image shipped on some Dell Latitude 2110 systems was accidentally configured to allow unauthenticated package installations. A remote attacker intercepting network communications or a malicious archive mirror server could exploit this to trick the user into installing unsigned packages, resulting in arbitrary code execution with root privileges.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 10.04 LTS
base-files - 5.0.0ubuntu20.10.04.2
Ubuntu 9.10
base-files - 5.0.0ubuntu7.1

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system update will make all the necessary changes.

References