USN-979-1: okular vulnerability

27 August 2010

kdegraphics vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 10.04 LTS
  • Ubuntu 9.10
  • Ubuntu 9.04

Summary

A heap-based buffer overflow in okular.

Software Description

  • kdegraphics - graphics applications from the official KDE 4 release

Details

Stefan Cornelius of Secunia Research discovered a boundary error during RLE decompression in the “TranscribePalmImageToJPEG()” function in generators/plucker/inplug/image.cpp of okular when processing images embedded in PDB files, which can be exploited to cause a heap-based buffer overflow. (CVE-2010-2575)

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 10.04 LTS
okular - 4:4.4.2-0ubuntu1.1
Ubuntu 9.10
okular - 4:4.3.2-0ubuntu1.1
Ubuntu 9.04
okular - 4:4.2.2-0ubuntu2.1

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

After a standard system update you need to restart any running instances of okular to make all the necessary changes.

References