USN-991-1: quassel vulnerability

23 September 2010

quassel vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 10.04 LTS
  • Ubuntu 9.10
  • Ubuntu 9.04

Summary

Software Description

  • quassel

Details

Jima discovered that quassel would respond to a single privmsg containing multiple CTCP requests with multiple NOTICEs, possibly resulting in a denial of service against the IRC connection.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 10.04 LTS
quassel - 0.6.1-0ubuntu1.1
quassel-core - 0.6.1-0ubuntu1.1
Ubuntu 9.10
quassel - 0.5.0-0ubuntu1.2
quassel-core - 0.5.0-0ubuntu1.2
Ubuntu 9.04
quassel - 0.4.1-0ubuntu3.1
quassel-core - 0.4.1-0ubuntu3.1

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

After a standard system update you need to restart quassel or quasselcore to make all the necessary changes.

References