USN-2399-1: curl vulnerability

Ubuntu Security Notice USN-2399-1

10th November, 2014

curl vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 14.10
  • Ubuntu 14.04 LTS
  • Ubuntu 12.04 LTS
  • Ubuntu 10.04 LTS

Summary

curl could expose sensitive information over the network.

Software description

  • curl - HTTP, HTTPS, and FTP client and client libraries

Details

Symeon Paraschoudis discovered that curl incorrectly handled memory when
being used with CURLOPT_COPYPOSTFIELDS and curl_easy_duphandle(). This may
result in sensitive data being incorrectly sent to the remote server.

Update instructions

The problem can be corrected by updating your system to the following package version:

Ubuntu 14.10:
libcurl3-nss 7.37.1-1ubuntu3.1
libcurl3-gnutls 7.37.1-1ubuntu3.1
libcurl3 7.37.1-1ubuntu3.1
Ubuntu 14.04 LTS:
libcurl3-nss 7.35.0-1ubuntu2.2
libcurl3-gnutls 7.35.0-1ubuntu2.2
libcurl3 7.35.0-1ubuntu2.2
Ubuntu 12.04 LTS:
libcurl3-nss 7.22.0-3ubuntu4.11
libcurl3-gnutls 7.22.0-3ubuntu4.11
libcurl3 7.22.0-3ubuntu4.11
Ubuntu 10.04 LTS:
libcurl3-gnutls 7.19.7-1ubuntu1.10
libcurl3 7.19.7-1ubuntu1.10

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system update will make all the necessary changes.

References

CVE-2014-3707