USN-2730-1: OpenSLP vulnerabilities

Ubuntu Security Notice USN-2730-1

3rd September, 2015

openslp-dfsg vulnerabilities

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 15.04
  • Ubuntu 14.04 LTS
  • Ubuntu 12.04 LTS

Summary

OpenSLP could be made to crash if it received specially crafted network traffic.

Software description

  • openslp-dfsg - OpenSLP development files

Details

Georgi Geshev discovered that OpenSLP incorrectly handled processing
certain service requests. A remote attacker could possibly use this issue
to cause OpenSLP to crash, resulting in a denial of service. This issue
only affected Ubuntu 12.04 LTS and Ubuntu 14.04 LTS. (CVE-2012-4428)

Qinghao Tang discovered that OpenSLP incorrectly handled processing certain
messages. A remote attacker could possibly use this issue to cause
OpenSLP to crash, resulting in a denial of service. (CVE-2015-5177)

Update instructions

The problem can be corrected by updating your system to the following package version:

Ubuntu 15.04:
libslp1 1.2.1-10ubuntu0.1
Ubuntu 14.04 LTS:
libslp1 1.2.1-9ubuntu0.2
Ubuntu 12.04 LTS:
libslp1 1.2.1-7.8ubuntu1.1

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system update will make all the necessary changes.

References

CVE-2012-4428, CVE-2015-5177