USN-3374-1: RabbitMQ vulnerability

Ubuntu Security Notice USN-3374-1

31st July, 2017

rabbitmq-server vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 16.04 LTS
  • Ubuntu 14.04 LTS

Summary

RabbitMQ could allow unintended access to network services.

Software description

  • rabbitmq-server - AMQP server written in Erlang

Details

It was discovered that RabbitMQ incorrectly handled MQTT (MQ Telemetry
Transport) authentication. A remote attacker could use this issue to
authenticate successfully with an existing username by omitting the
password.

Update instructions

The problem can be corrected by updating your system to the following package version:

Ubuntu 16.04 LTS:
rabbitmq-server 3.5.7-1ubuntu0.16.04.2
Ubuntu 14.04 LTS:
rabbitmq-server 3.2.4-1ubuntu0.1

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system update will make all the necessary changes.

References

CVE-2016-9877