USN-3407-1: PyJWT vulnerability

Ubuntu Security Notice USN-3407-1

30th August, 2017

pyjwt vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 17.04
  • Ubuntu 16.04 LTS

Summary

PyJWT could be made to crash if it received specially crafted input.

Software description

  • pyjwt - Python implementation of JSON Web Token

Details

It was discovered that a vulnerability in PyJWT doesn't check
invalid_strings properly for some public keys. A remote attacker
could take advantage of a key confusion to craft JWTs from scratch.

Update instructions

The problem can be corrected by updating your system to the following package version:

Ubuntu 17.04:
python-jwt 1.4.2-1ubuntu0.1
python3-jwt 1.4.2-1ubuntu0.1
Ubuntu 16.04 LTS:
python-jwt 1.3.0-1ubuntu0.1
python3-jwt 1.3.0-1ubuntu0.1

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system update will make all the necessary changes.

References

CVE-2017-11424