USN-3410-1: GD library vulnerability

Ubuntu Security Notice USN-3410-1

5th September, 2017

libgd2 vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 17.04
  • Ubuntu 16.04 LTS
  • Ubuntu 14.04 LTS

Summary

GD library could be made to crash if it opened a specially crafted file.

Software description

  • libgd2 - GD Graphics Library

Details

It was discovered that the GD Graphics Library (aka libgd) incorrectly handled
certain malformed PNG images. A remote attacker could use this issue to cause the GD Graphics Library
to crash, resulting in a denial of service, or possibly execute arbitrary code.

Update instructions

The problem can be corrected by updating your system to the following package version:

Ubuntu 17.04:
libgd3 2.2.4-2ubuntu0.3
libgd-tools 2.2.4-2ubuntu0.3
Ubuntu 16.04 LTS:
libgd3 2.1.1-4ubuntu0.16.04.8
libgd-tools 2.1.1-4ubuntu0.16.04.8
Ubuntu 14.04 LTS:
libgd3 2.1.0-3ubuntu0.8
libgd-tools 2.1.0-3ubuntu0.8

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system update will make all the necessary changes.

References

CVE-2017-6362