USN-3421-1: Libidn2 vulnerability

Ubuntu Security Notice USN-3421-1

18th September, 2017

libidn2-0 vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 17.04

Summary

Libidn2 could be made to crash if it received specially crafted input.

Software description

  • libidn2-0 - Internationalized domain names (IDNA2008) library

Details

It was discovered that Libidn2 incorrectly handled certain input. A
remote attacker could possibly use this issue to cause Libidn2 to crash,
resulting in a denial of service.

Update instructions

The problem can be corrected by updating your system to the following package version:

Ubuntu 17.04:
libidn2-0 0.16-1ubuntu0.1
idn2 0.16-1ubuntu0.1

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system update will make all the necessary changes.

References

CVE-2017-14062