USN-3433-1: poppler vulnerabilities

Ubuntu Security Notice USN-3433-1

2nd October, 2017

poppler vulnerabilities

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 17.04
  • Ubuntu 16.04 LTS
  • Ubuntu 14.04 LTS

Summary

poppler could be made to crash if opened a specially crafted file.

Software description

  • poppler - PDF rendering library

Details

It was discovered that Poppler incorrectly handled certain files.
If a user or automated system were tricked into opening a
crafted PDF file, an attacker could cause a denial service.
This issue only affected Ubuntu 17.04. (CVE-2017-14517)

It was discovered that Poppler incorrectly handled certain files.
If a user or automated system were tricked into opening a crafted PDF file,
an attacker could cause a denial of service. (CVE-2017-14519)

Update instructions

The problem can be corrected by updating your system to the following package version:

Ubuntu 17.04:
libpoppler64 0.48.0-2ubuntu2.2
poppler-utils 0.48.0-2ubuntu2.2
Ubuntu 16.04 LTS:
libpoppler58 0.41.0-0ubuntu1.3
poppler-utils 0.41.0-0ubuntu1.3
Ubuntu 14.04 LTS:
poppler-utils 0.24.5-2ubuntu4.6
libpoppler44 0.24.5-2ubuntu4.6

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system update will make all the necessary changes.

References

CVE-2017-14517, CVE-2017-14519