USN-3437-1: OCaml vulnerability

Ubuntu Security Notice USN-3437-1

3rd October, 2017

ocaml vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 14.04 LTS

Summary

OCaml applications could be made to crash, expose sensitive information, or run programs.

Software description

  • ocaml - ML language implementation with a class-based object system

Details

Radek Micek discovered that OCaml incorrectly handled sign extensions. A
remote attacker could use this issue to cause applications using OCaml to
crash, to possibly obtain sensitive information, or to possibly execute
arbitrary code.

Update instructions

The problem can be corrected by updating your system to the following package version:

Ubuntu 14.04 LTS:
ocaml 4.01.0-3ubuntu3.1

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system update will make all the necessary changes.

References

CVE-2015-8869