USN-3458-1: ICU vulnerability

Ubuntu Security Notice USN-3458-1

23rd October, 2017

icu vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 17.10
  • Ubuntu 17.04
  • Ubuntu 16.04 LTS
  • Ubuntu 14.04 LTS

Summary

ICU could be made to crash or run arbitrary code as your login if it received specially crafted input.

Software description

  • icu - International Components for Unicode library

Details

It was discovered that ICU incorrectly handled certain inputs. If an
application using ICU processed crafted data, a remote attacker could
possibly cause it to crash or potentially execute arbitrary code with
the privileges of the user invoking the program.

Update instructions

The problem can be corrected by updating your system to the following package version:

Ubuntu 17.10:
libicu57 57.1-6ubuntu0.2
Ubuntu 17.04:
libicu57 57.1-5ubuntu0.2
Ubuntu 16.04 LTS:
libicu55 55.1-7ubuntu0.3
Ubuntu 14.04 LTS:
libicu52 52.1-3ubuntu0.7

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system update will make all the necessary changes.

References

CVE-2017-14952