USN-3518-1: AWStats vulnerability

Ubuntu Security Notice USN-3518-1

8th January, 2018

awstats vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 17.10
  • Ubuntu 17.04
  • Ubuntu 16.04 LTS
  • Ubuntu 14.04 LTS

Summary

AWStats could be made to run programs if it received specially crafted network traffic.

Software description

  • awstats - powerful and featureful web server log analyzer

Details

It was discovered that AWStats incorrectly filtered certain parameters. A
remote attacker could possibly use this issue to execute arbitrary code.

Update instructions

The problem can be corrected by updating your system to the following package version:

Ubuntu 17.10:
awstats 7.6+dfsg-1ubuntu0.17.10.1
Ubuntu 17.04:
awstats 7.6+dfsg-1ubuntu0.17.04.1
Ubuntu 16.04 LTS:
awstats 7.4+dfsg-1ubuntu0.2
Ubuntu 14.04 LTS:
awstats 7.2+dfsg-1ubuntu0.1

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system update will make all the necessary changes.

References

CVE-2017-1000501