USN-1068-1: Aptdaemon vulnerability

22 February 2011

aptdaemon vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 10.10

Summary

Software Description

  • aptdaemon

Details

Sergey Nizovtsev discovered that Aptdaemon incorrectly filtered certain arguments when using its D-Bus interface. A local attacker could use this flaw to bypass security restrictions and view sensitive information by reading arbitrary files.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 10.10
python-aptdaemon - 0.31+bzr506-0ubuntu6.1

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system update will make all the necessary changes.

References