USN-1298-1: Apache Commons Daemon vulnerability

12 December 2011

commons-daemon vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 11.10
  • Ubuntu 11.04

Summary

Apache Commons Daemon would allow unintended access to files over the network.

Software Description

  • commons-daemon - wrapper to launch Java applications as daemons

Details

Wilfried Weissmann discovered that Apache Commons Daemon incorrectly dropped capabilities after starting. A remote attacker could possibly use this flaw to read certain files, bypassing the intended permissions.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 11.10
libcommons-daemon-java - 1.0.6-1ubuntu0.1
Ubuntu 11.04
libcommons-daemon-java - 1.0.4-1ubuntu0.1

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

After a standard system update you need to restart applications which use Apache Commons Daemon, such as the Jetty web server, to make all the necessary changes.

References