USN-1398-1: LTSP Display Manager vulnerability

12 March 2012

ldm vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 11.10
  • Ubuntu 11.04

Summary

LTSP Display Manager could be made to run programs as an administrator.

Software Description

  • ldm - LTSP display manager

Details

Tenho Tuhkala discovered that the LTSP Display Manager (ldm) incorrectly filtered keybindings. An attacker could use the default keybindings to execute arbitrary commands as root at the login screen.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 11.10
ldm - 2:2.2.4-0ubuntu1.1
Ubuntu 11.04
ldm - 2:2.2.1-0ubuntu1.1

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

After a standard system update you need to restart the LTSP Display Manager to make all the necessary changes.

References