USN-1428-1: OpenSSL vulnerability

24 April 2012

openssl vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 11.10
  • Ubuntu 11.04
  • Ubuntu 10.04 LTS
  • Ubuntu 8.04 LTS

Summary

An application using OpenSSL could be made to crash or run programs if it opened a specially crafted file.

Software Description

  • openssl - Secure Socket Layer (SSL) cryptographic library and tools

Details

It was discovered that the fix for CVE-2012-2110 was incomplete for OpenSSL 0.9.8. A remote attacker could trigger this flaw in services that used SSL to cause a denial of service or possibly execute arbitrary code with application privileges. Ubuntu 11.10 was not affected by this issue. (CVE-2012-2131)

The original upstream fix for CVE-2012-2110 would cause BUF_MEM_grow_clean() to sometimes return the wrong error condition. This update fixes the problem.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 11.10
libssl1.0.0 - 1.0.0e-2ubuntu4.5
Ubuntu 11.04
libssl0.9.8 - 0.9.8o-5ubuntu1.5
Ubuntu 10.04 LTS
libssl0.9.8 - 0.9.8k-7ubuntu8.11
Ubuntu 8.04 LTS
libssl0.9.8 - 0.9.8g-4ubuntu3.18

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

After a standard system update you need to reboot your computer to make all the necessary changes.

References