USN-2341-1: CUPS vulnerabilities

8 September 2014

cups vulnerabilities

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 14.04 LTS
  • Ubuntu 12.04 LTS
  • Ubuntu 10.04 LTS

Summary

CUPS could be made to expose sensitive information, leading to privilege escalation.

Software Description

  • cups - Common UNIX Printing System™

Details

Salvatore Bonaccorso discovered that the CUPS web interface incorrectly validated permissions and incorrectly handled symlinks. An attacker could possibly use this issue to bypass file permissions and read arbitrary files, possibly leading to a privilege escalation.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 14.04 LTS
cups - 1.7.2-0ubuntu1.2
Ubuntu 12.04 LTS
cups - 1.5.3-0ubuntu8.5
Ubuntu 10.04 LTS
cups - 1.4.3-1ubuntu1.13

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system update will make all the necessary changes.

References