USN-2425-1: DBus vulnerability

27 November 2014

dbus vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 14.10
  • Ubuntu 14.04 LTS
  • Ubuntu 12.04 LTS

Summary

DBus could be made to stop responding under certain conditions.

Software Description

  • dbus - simple interprocess messaging system

Details

It was discovered that DBus incorrectly handled a large number of file descriptor messages. A local attacker could use this issue to cause DBus to stop responding, resulting in a denial of service. (CVE-2014-7824)

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 14.10
dbus - 1.8.8-1ubuntu2.1
libdbus-1-3 - 1.8.8-1ubuntu2.1
Ubuntu 14.04 LTS
dbus - 1.6.18-0ubuntu4.3
libdbus-1-3 - 1.6.18-0ubuntu4.3
Ubuntu 12.04 LTS
dbus - 1.4.18-1ubuntu1.7
libdbus-1-3 - 1.4.18-1ubuntu1.7

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

After a standard system update you need to reboot your computer to make all the necessary changes.

References