USN-2531-1: Requests vulnerability

16 March 2015

requests vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 14.10
  • Ubuntu 14.04 LTS

Summary

Requests could be made to expose cookies over the network.

Software Description

  • requests - elegant and simple HTTP library for Python

Details

Matthew Daley discovered that Requests incorrectly handled cookies without host values when being redirected. A remote attacker could possibly use this issue to perform session fixation or cookie stealing attacks.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 14.10
python-requests - 2.3.0-1ubuntu0.1
python3-requests - 2.3.0-1ubuntu0.1
Ubuntu 14.04 LTS
python-requests - 2.2.1-1ubuntu0.2
python3-requests - 2.2.1-1ubuntu0.2

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system update will make all the necessary changes.

References