USN-2905-1: Oxide vulnerability

23 February 2016

oxide-qt vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 15.10
  • Ubuntu 14.04 LTS

Summary

Oxide could be made to bypass same-origin restrictions.

Software Description

  • oxide-qt - Web browser engine library for Qt (QML plugin)

Details

A security issue was discovered in Chromium. If a user were tricked in to opening a specially crafted website, an attacker could potentially exploit this to bypass same-origin restrictions or a sandbox protection mechanism. (CVE-2016-1629)

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 15.10
liboxideqtcore0 - 1.12.7-0ubuntu0.15.10.1
Ubuntu 14.04 LTS
liboxideqtcore0 - 1.12.7-0ubuntu0.14.04.1

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system update will make all the necessary changes.

References