USN-3565-1: Exim vulnerability

12 February 2018

exim4 vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 17.10
  • Ubuntu 16.04 LTS
  • Ubuntu 14.04 LTS

Summary

Exim could be made to crash or run programs if it received specially crafted network traffic.

Software Description

  • exim4 - Exim is a mail transport agent

Details

Meh Chang discovered that Exim incorrectly handled memory in certain decoding operations. A remote attacker could use this issue to cause Exim to crash, resulting in a denial of service, or possibly execute arbitrary code.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 17.10
exim4-daemon-heavy - 4.89-5ubuntu1.3
exim4-daemon-light - 4.89-5ubuntu1.3
Ubuntu 16.04 LTS
exim4-daemon-heavy - 4.86.2-2ubuntu2.3
exim4-daemon-light - 4.86.2-2ubuntu2.3
Ubuntu 14.04 LTS
exim4-daemon-heavy - 4.82-3ubuntu2.4
exim4-daemon-light - 4.82-3ubuntu2.4

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system update will make all the necessary changes.

References