USN-3647-1: poppler vulnerabilities

15 May 2018

poppler vulnerabilities

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 18.04 LTS
  • Ubuntu 17.10
  • Ubuntu 16.04 LTS
  • Ubuntu 14.04 LTS

Summary

poppler could be made to crash if it opened a specially crafted PDF.

Software Description

  • poppler - PDF rendering library

Details

It was discovered that poppler incorrectly handled certain PDF files. An attacker could possibly use this to cause a denial of service. (CVE-2017-18267)

It was discovered that poppler incorrectly handled certain PDF files. An attacker could possibly use this to cause a denial of service. This issue only affected Ubuntu 14.04 LTS. (CVE-2018-10768)

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 18.04 LTS
libpoppler73 - 0.62.0-2ubuntu2.1
poppler-utils - 0.62.0-2ubuntu2.1
Ubuntu 17.10
libpoppler68 - 0.57.0-2ubuntu4.3
poppler-utils - 0.57.0-2ubuntu4.3
Ubuntu 16.04 LTS
libpoppler58 - 0.41.0-0ubuntu1.7
poppler-utils - 0.41.0-0ubuntu1.7
Ubuntu 14.04 LTS
libpoppler44 - 0.24.5-2ubuntu4.11
poppler-utils - 0.24.5-2ubuntu4.11

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system update will make all the necessary changes.

References