USN-3667-1: libytnef vulnerabilities

31 May 2018

libytnef vulnerabilities

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 14.04 LTS

Summary

Several security issues were fixed in libytnef.

Software Description

  • libytnef - improved decoder for application/ms-tnef attachments

Details

It was discovered that libytnef incorrectly handled certain files. An attacker could possibly use this to cause a denial of service. (CVE-2017-12141, CVE-2017-9146, CVE-2017-9471, CVE-2017-9473)

It was discovered that libytnef incorrectly handled certain files. An attacker could possibly use this to access sensitive information. (CVE-2017-9058)

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 14.04 LTS
libytnef0 - 1.5-6ubuntu0.2

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

After a standard system update you need to restart applications using libytnef, such as Evolution, to make all the necessary changes.

References