USN-4120-1: systemd vulnerability

3 September 2019

systemd vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 19.04
  • Ubuntu 18.04 LTS

Summary

systemd-resolved would allow unprivileged users to change DNS settings.

Software Description

  • systemd - system and service manager

Details

It was discovered that the systemd-resolved D-Bus interface did not enforce appropriate access controls. A local unprivileged user could exploit this to modify a system’s DNS resolver settings.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 19.04
systemd - 240-6ubuntu5.6
Ubuntu 18.04 LTS
systemd - 237-3ubuntu10.28

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

After a standard system update you need to reboot your computer to make all the necessary changes.

References