USN-4139-1: File Roller vulnerability

25 September 2019

file-roller vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 18.04 LTS
  • Ubuntu 16.04 LTS

Summary

File Roller could be made to overwrite sensitive files if it received a specially crafted TAR file.

Software Description

  • file-roller - archive manager for GNOME

Details

It was discovered that File Roller incorrectly handled certain TAR files. An attacker could possibly use this issue to overwrite sensitive files during extraction.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 18.04 LTS
file-roller - 3.28.0-1ubuntu1.1
Ubuntu 16.04 LTS
file-roller - 3.16.5-0ubuntu1.3

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system update will make all the necessary changes.

References